orgize/shell.nix

11 lines
338 B
Nix

# [[id:13995d53-320a-4955-996a-4a4a25319701][No heading:2]]
let
pkgs = import <nixpkgs> {};
in pkgs.mkShell {
packages = with pkgs; [ cargo rustc rust-analyzer rustfmt clippy ];
nativeBuildInputs = with pkgs; [ rustc cargo gcc ];
RUST_SRC_PATH = "${pkgs.rust.packages.stable.rustPlatform.rustLibSrc}";
}
# No heading:2 ends here